Create an install service from a downloaded ISO file, specifying x86 based DHCP
client starting at address 192.168.1.210 with a total count of 10 addresses:
# installadm create-service -n s11x86 -i 192.168.1.210 -c 10 -s
/path/to/solaris-11-1111-ai-x86.iso
List all enabled services:
# installadm list
List any installation manifests associated with the install services:
# installadm list -m
Export the default installation manifest associated with the s11x86 service:
# installadm export -n s11x86 -m orig_default > manifest.xml
Import a manifest to be associated with the s11x86 service:
# installadm update-manifest -n s11x86 -m orig_default \
-f manifest.xml
List any system configuration profiles associated with the install services:
# installadm list -p
Create a system configuration profile interactively, saving the contents to a file:
# sysconfig create-profile -o profile.xml
Validate a system configuration profile against the default x86 install service:
# installadm validate -n default-i386 -P profile.xml
Associate a system configuration profile with the deafult x86 install service and
give it a name sc-profile:
# installadm create-profile -n default-i386 -f profile.xml \
-p sc-profile
Apply a criteria that all clients must have 4096MB memory or greater to the
manifest s11manifest of s11x86 service:
# installadm set-criteria -m s11manifest -n s11x86 \
-a MEM="4096-unbounded"Configuring nodename:
# svccfg –s svc:/system/identity:node setprop \
config/nodename = "myhost"
# svcadm refresh svc:/system/identity:node
# svcadm restart svc:/system/identity:node
Configuring console keyboard layout:
# svccfg –s keymap:default setprop keymap/layout = UK-English
# svcadm refresh keymap
# svcadm restart keymap
Configuring system locale:
# svccfg –s timezone:default setprop \
timezone/localtime = astring: US/Mountain
# svcadm refresh timezone:default
Unconfigure a system and start an interactive configuration tool on reboot:
# sysconfig configure -s
Create a system configuration profile:
# sysconfig create-profile -o sc-profile.xml
Configure a system according to a system configuration profile:
# sysconfig configure -c sc-profile.xml
***************************************************************
Revert to root as normal user account:
# rolemod –K type=normal root
Configure root as a role (default):
# usermod –K type=role root
Add a new user and delegate him the System Adminstrator profile:
# useradd -d /export/home/joerg -P "System Administrator" joerg
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Create a boot environment:
# beadm create solaris-05032012
Activate a boot environment:
# beadm activate solaris-05032012
Delete a boot environment:
# beadm destroy solaris-05032012
Show boot environments from SPARC boot PROM:
ok boot -L
Boot into a boot environment from SPARC boot PROM:
ok boot -Z rpool/ROOT/solaris-05032012
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
PKG Commands
Install a package called diagnostic/wireshark:
# pkg install diagnostic/wireshark
Install a group package to provide a desktop environment:
# pkg install solaris-desktop
Update all possible packages to the newest version, including any zones:
# pkg update
Do a dry run of a system update to understand what packages may change:
# pkg update -nv
Uninstall a package called diagnostic/wireshark:
# pkg uninstall wireshark
List all packages installed on a system:
# pkg list
Get more information about an installed package called diagnostic/wireshark:
# pkg info wireshark
List the contents of an installed package called diagnostic/wireshark:
# pkg contents wireshark
Search all packages in the configured repositories for a file called math.h:
# pkg search math.h
Search for all packages installed on a system that have a dependency on
library/libxml2:
# pkg search -l -o pkg.name 'depend::library/libxml2'
List currently associated package publishers:
# pkg publisher
Connect to the Oracle support repository and update the system:
# pkg set-publisher -g https://pkg.oracle.com/solaris/support \
-G http://pkg.oracle.com/solaris/release -k /path/to/ssl_key \
-c /path/to/ssl_cert solaris
# pkg update
____________________________________________________________________
ZFS commands
Create a ZFS pool with a single disk:
# zpool create testpool c3t2d0
Create a ZFS pool with 3 disks in RAID0 configuration:
# zpool create testpool c3t2d0 c3t3d0 c3t4d0
Create a ZFS pool with 3 disks in RAID1 configuration:
# zpool create testpool mirror c3t2d0 c3t3d0 c3t4d0
Create a ZFS pool with 3 disks in a RAIDZ configuration (single parity):
# zpool create testpool raidz c2t2d0 c3t3d0 c3t4d0
Create a ZFS pool with 1 disk and 1 disk as seperate ZIL (ZFS Intent Log):
# zpool create testpool c3t2d0 log c3t3d0
Create a ZFS pool with 1 disk and 1 disk as L2ARC (Level 2 storage cache):
# zpool create testpool c3t2d0 cache c3t3d0
Share a filesystem via NFS:
# zfs create zpool/fs1
# zfs set share=name=fs1,path=/rpool/fs1,prot=nfs rpool/fs1
# zfs set sharenfs=on rpool/fs1
Share a filesystem via CIFS:
# pkg install service/filesystem/smb
# svcadm enable -r smb/server
# echo "other password required pam_smb_passwd.so.1 nowarn" \
>> /etc/pam.conf
# smbadm enable-user joerg
# zfs set share=name=sh1,path=/rpool/fs1,prot=smb rpool/fs1
# zfs set sharesmb=on rpool/fs1
Use shadow migration:
# pkg install shadow-migration
# svcadm enable shadowd
# zfs set readonly=on path/to/data
# zfs create -o shadoow=file:///path/to/data \
target/new/path/to/data
You can find solutions to issues for various UNIX operating systems Cloud and DevOps here. Also this site provides you career guidance to the beginners looking for a career as UNIX/ DevOps Engineers/ Administrator.
Subscribe to:
Post Comments (Atom)
Installing Ingress Controller - Kubernetes
Installing the Ingress Controller Prerequisites Make sure you have access to the Ingress controller image: For NGINX Ingress controll...
-
Decommission of LDOM ========================= ldm stop samplepdtestsun08 ldm unbind samplepdtestsun08 ldm destroy samplepdtestsun08 ...
-
hey guys I really felt happy on receiving lot of response to this blog which keep the spirit high in continue writing this. ok I will contin...
-
OS: Sun Solaris 8/10 Hardware: Fire-V880 Error Message: df: cannot statvfs /oracle/test/vol158: I/O error df: cannot statvfs /oracle/test/vo...
No comments:
Post a Comment